No announcement yet.

YUM update broken

  • Filter
  • Time
  • Show
Clear All
new posts

  • YUM update broken

    Hi all,
    When I do a yum update I get the below output. If anyone can help me resolve this it would be much appreciated.

    [root@localhost ~]# yum update
    Loaded plugins: fastestmirror, rhnplugin
    This system is receiving updates from CLN.
    Loading mirror speeds from cached hostfile
    * cloudlinux-x86_64-server-7:
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv&#91;1:&#93;, exit_code=True)
    File "/usr/share/yum-cli/", line 365, in user_main
    errcode = main(args)
    File "/usr/share/yum-cli/", line 174, in main
    result, resultmsgs = base.doCommands()
    File "/usr/share/yum-cli/", line 573, in doCommands
    return self.yum_cli_commands&#91;self.basecmd&#93;.doComm and(self, self.basecmd, self.extcmds)
    File "/usr/share/yum-cli/", line 500, in doCommand
    ret = base.updatePkgs(extcmds, update_to=(basecmd == update-to))
    File "/usr/share/yum-cli/", line 1015, in updatePkgs
    File "/usr/lib/python2.7/site-packages/yum/", line 5085, in update
    updates = self.up.getUpdatesTuples()
    File "/usr/lib/python2.7/site-packages/yum/", line 1098, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
    File "/usr/lib/python2.7/site-packages/yum/", line 844, in _getUpdates
    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList( ), self.pkgSack.simplePkgList())
    File "/usr/lib/python2.7/site-packages/yum/", line 1079, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
    File "/usr/lib/python2.7/site-packages/yum/", line 784, in _getSacks
    File "/usr/lib/python2.7/site-packages/yum/", line 383, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
    File "/usr/lib/python2.7/site-packages/yum/", line 224, in populate
    if self._check_db_version(repo, mydbtype):
    File "/usr/lib/python2.7/site-packages/yum/", line 316, in _check_db_version
    return repo._check_db_version(mdtype)
    File "/usr/lib/python2.7/site-packages/yum/", line 1484, in _check_db_version
    repoXML = self.repoXML
    File "/usr/lib/python2.7/site-packages/yum/", line 1670, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
    File "/usr/share/yum-plugins/", line 614, in _getRepoXML
    return YumRepository._getRepoXML(self)
    File "/usr/lib/python2.7/site-packages/yum/", line 1666, in _getRepoXML
    File "/usr/lib/python2.7/site-packages/yum/", line 1657, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
    File "/usr/lib/python2.7/site-packages/yum/", line 1631, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
    File "/usr/lib/python2.7/site-packages/yum/", line 1456, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
    File "/usr/lib/python2.7/site-packages/yum/", line 1234, in _getFileRepoXML
    size=102400) # setting max size as 100K
    File "/usr/share/yum-plugins/", line 427, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache, size)
    File "/usr/share/yum-plugins/", line 506, in _noExceptionWrappingGet
    size = size
    File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1172, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
    File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1064, in _retry
    r = apply(func, (opts,) + args, {})
    File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1157, in retryfunc
    fo = PyCurlFileObject(url, filename, opts)
    File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1258, in __init__
    File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1589, in _do_open
    File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1413, in _set_opts
    self.curl_obj.setopt(pycurl.CAPATH, opts.ssl_ca_cert)
    pycurl.error: (4, \)
    &#91;root@localhost ~&#93;#

  • #2
    Have you tried
    yum clean all


    • #3
      I tried this and still get the above error

      yum clean all
      rm -f /var/lib/rpm/__db*
      rpm --rebuilddb
      yum update