No announcement yet.

Error: Cant enter to lve from slave context

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error: Cant enter to lve from slave context

    On php script petition

  • #2

    We are testing lve with mod_fcgid and we are receiving this error. Dont know at this moment why it happens.

    Error: Can enter to lve from slave context user_id

    Thanks in advance


    • #3
      Usually this is due to conflict between mod_hostinglimits and mod_fcgid
      Could you disable mod_hostinglimits and see if that resolves the issue.
      If it does -- you need to go through AddHandlers in modhostinglimits.conf and remove those that are handled by mod_fcgid.

      What control panel are you using?


      • #4
        That was correct,

        Once we commented the mod_hostinglimits handlers it worked fine. We are using cpanel with mod_fcgid .

        Thanks a lot


        • #5
          Are you using MPM Worker or MPM Prefork?
          If pre-fork -- you still want mod_hostinglimits for CGI scripts.
          Edit modhostinglimits.conf
          And remove all handlers related to PHP, after that you should be able to re-enable it.

          Also, how did you install mod_fcgid, via install-lve, or via latest cpanel-lve?
          I want to try to replicate the issue in house. It should have worked out of the box.


          • #6

            The thing is that we did a conversion centos to clodlinux , mod_fcgid is installed with cpanel tools afaik. I think it should work fine with the out-of-the-box configuration since we have some custom modifications in the mod_fcgid configuration for the php handlers. The conflict between the modules is normal once you see modhostinglimits.conf content and custom modifications. But with the enable lve 0N for mod_fcgid it works ok once you edit the handlers. We are using prefork in apache.