Announcement

Collapse
No announcement yet.

MariaDB 5.5 on CloudLinux 7 hard lock ups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bogdan.sh
    replied
    Hi,

    Well, this is a pretty hard question, and in most cases, it is related to a specific website or configuration of a server.

    The investigation path is same for servers with CloudLinux or without it. Start with a simple "SHOW PROCESSLIST;" to get the understanding of what those connections are, and if they are going from a single user/website. What to look for - State and Info in a resulting table.

    Here is a good explanation of how it works: https://stackoverflow.com/questions/...ny-connections

    Leave a comment:


  • Miguel Varela
    replied
    Hey Dima,

    Hope you're well! :-)

    Have you checked which processes are using those connections?

    Maybe it'd be worth opening a ticket with us in our support portal so we can investigate this properly, https://www.cloudlinux.com/support-portal/


    Cheers!

    Leave a comment:


  • dima
    started a topic MariaDB 5.5 on CloudLinux 7 hard lock ups

    MariaDB 5.5 on CloudLinux 7 hard lock ups

    From time to time the native MariaDB server (Server version: 5.5.68-MariaDB-cll-lve MariaDB Server) locks up with too many connections on most of our servers.
    I can't figure out why. The only way to make it work again is to kill mysqld processes "killall -9 mysqld" then letting systemctl restart it.

    When it lock up it uses all connections available to the database server (ie. I set max connections to 150, then all 150 is in use in case of the lockup) and queries are in a waiting state. I can not even kill specific connections to free them up, I need to kill the entire server.

    I tweaked innodb cache size and related settings but it did not help at all. If I set max connections to 800, then 800 will be in use when the lockup happens.

    I did not experience anything like this on other OSes. I tried to look for specific bugs for this specific version.


    Please help me fix this issue, it is getting really annoying.
Working...
X