Announcement

Collapse
No announcement yet.

Suggestion Change for end Users Hitting Limits?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Suggestion Change for end Users Hitting Limits?

    Hi I am getting more End Users hitting limits messages. I am not sure how to read this log. Is there any suggested action I can/should take?

    Click image for larger version

Name:	image.png
Views:	660
Size:	73.5 KB
ID:	39183Click image for larger version

Name:	image.png
Views:	660
Size:	29.7 KB
ID:	39184

    Click image for larger version

Name:	image.png
Views:	640
Size:	103.2 KB
ID:	39185​​
    Attached Files

  • #2
    Hi,

    You have done a great job digging into it. Unfortunately, screenshots size is to low to read it properly. Anyway, after guessing I believe they are all about hitting the IO limits. And most of them happened with the wp-admin/update.php . The limit of 1Mb/s seems is not enough during some updates or uploads, especially if websites have some other plugins installed.

    I would suggest increasing the IO limit to 2Mb/s for the default package.

    Comment


    • #3
      I have doubled all of the resource limits on the VM, and I am still having limit issues. I don't know what I am doing wrong here.

      I run a Dell Poweredge R530 with DUAL 18C/32T Processors and 384 GB memory. I have 24TB of Disk Space as well. (RAID 10 SAS Drives)

      [root@managed01 ~]# lve-read-snapshot --period 7d --user zzxrXXXX
      Snapshots collected starting from 2023-03-13T17:08:43 to 2023-03-20T17:08:43 for lve id 1002 @ 3f0a5078-0:
      >>> 2023-03-19T13:05:42, UID 1002

      Faults:
      * IO: 1

      Processes:
      +--------+-------------+---------+----------------------------------------------------+
      | PID | Memory (Mb) | CPU (%) | CMD |
      +--------+-------------+---------+----------------------------------------------------+
      | 155221 | 38 | 2 | lsphp:XXXX/public_html/wp-admin/update.php |
      | 154843 | 5 | 0 | lsphp |
      +--------+-------------+---------+----------------------------------------------------+

      Http requests:
      +-------+--------------------+-----------+------------------------------------------+--------------+------+
      | Pid | Domain | Http type | Path | Http version | Time |
      +-------+--------------------+-----------+------------------------------------------+--------------+------+
      | 16484 | XXXX.com | POST | /wp-admin/update.php?action=upload-theme | HTTP/1.1 | 6.4 |
      +-------+--------------------+-----------+------------------------------------------+--------------+------+

      >>> 2023-03-19T13:14:14, UID 1002

      Faults:
      * IO: 1

      Processes:
      +--------+-------------+---------+----------------------------------------------------+
      | PID | Memory (Mb) | CPU (%) | CMD |
      +--------+-------------+---------+----------------------------------------------------+
      | 156398 | 35 | 5 | lsphp:XXXX/public_html/wp-admin/update.php |
      | 156150 | 5 | 0 | lsphp |
      +--------+-------------+---------+----------------------------------------------------+

      Http requests:
      +-------+--------------------+-----------+-------------------------------------------+--------------+------+
      | Pid | Domain | Http type | Path | Http version | Time |
      +-------+--------------------+-----------+-------------------------------------------+--------------+------+
      | 16484 | XXXX.com | POST | /wp-admin/update.php?action=upload-plugin | HTTP/1.1 | 15.3 |
      +-------+--------------------+-----------+-------------------------------------------+--------------+------+

      >>> 2023-03-19T13:15:44, UID 1002

      Faults:
      * IO: 1

      Processes:
      +--------+-------------+---------+----------------------------------------------------+
      | PID | Memory (Mb) | CPU (%) | CMD |
      +--------+-------------+---------+----------------------------------------------------+
      | 156806 | 42 | 9 | lsphp:XXXX/public_html/wp-admin/update.php |
      | 156150 | 5 | 0 | lsphp |
      +--------+-------------+---------+----------------------------------------------------+

      Done..
      [root@managed01 ~]#​

      Click image for larger version

Name:	image.png
Views:	598
Size:	27.8 KB
ID:	39206

      Comment


      • #4
        [root@managed01 ~]# lve-read-snapshot --period 7d --user XXXX
        Snapshots collected starting from 2023-03-13T17:19:08 to 2023-03-20T17:19:08 for lve id 1004 @ 3f0a5078-0:
        >>> 2023-03-19T14:25:26, UID 1004

        Faults:
        * IO: 2

        Processes:
        +--------+-------------+---------+----------------------------------------------------+
        | PID | Memory (Mb) | CPU (%) | CMD |
        +--------+-------------+---------+----------------------------------------------------+
        | 167015 | 36 | 3 | lsphp:XXXX/public_html/wp-admin/update.php |
        | 166380 | 5 | 0 | lsphp |
        +--------+-------------+---------+----------------------------------------------------+

        Http requests:
        +-------+----------------+-----------+-------------------------------------------+--------------+------+
        | Pid | Domain | Http type | Path | Http version | Time |
        +-------+----------------+-----------+-------------------------------------------+--------------+------+
        | 16484 | XXXX.com | POST | /wp-admin/update.php?action=upload-plugin | HTTP/1.1 | 7.5 |
        +-------+----------------+-----------+-------------------------------------------+--------------+------+

        Done..
        [root@managed01 ~]#​

        Comment


        • #5

          Here are more photos to help diagnose the issue.Click image for larger version

Name:	image.png
Views:	578
Size:	45.6 KB
ID:	39209

          Comment


          • #6
            Also, what are the EP Faults? How do I stop those?

            Comment


            • #7
              EP stands for Entry Processes limit, in very short they are concurrent connections to PHP. From the screenshot you provided they are not happening on your server, the faults are related only to IO. It's formatting-related IO (A | L | F ).

              For IO it still says during WordPress plugin upgrade it's hitting the limit and the reason is well explained - the disk operations are extensive. Nothing wrong here, CloudLinux is perfectly doing its job - it limits those processes that are overusing the IO speed. Do you mean that SAAS drives are NVMe? If so then definitely you may increase IO limit even more (to 40M/s), or even make it unlimited.

              Thanks for the screenshots, they helped a lot!

              Comment


              • #8
                Bogdan thank you for your help.

                I am running CloudLinux on a PowerEdge r530 with Dual 18C/36T CPU and 384GB Memory with 8x6 TB drives in RAID 10 (24TB Useable Space)

                My drives are Hitachi 6TB SAS drives - Here are the specs: https://drivesolutions.com/hitachi-u...-512e-ise.html

                If this were your server what would you set all the settings at? The default settings keep hitting limits and I do have a lot of power under the hood on these servers that I can use.


                Click image for larger version

Name:	image.png
Views:	582
Size:	66.9 KB
ID:	39218

                Comment


                • #9
                  The issue is actually not an issue at all. The users are hitting Input-Output limits during the highly intensive disk operations (Wordpress update). You should not comply with all the faults, they are normal in this case.

                  The specifications you have sent are related to regular drives, if I were you I would keep IO limit at 20MB/s. The power of CloudLinux is to prevent one user from overloading a server while those drives could be a bottleneck in the future.

                  Comment

                  Working...
                  X