No announcement yet.

Hook denied modification of account

  • Filter
  • Time
  • Show
Clear All
new posts

  • Hook denied modification of account

    Cant modify an account in WHM without entering individual settings for LVE limits. WHM 64.0 (build 36)

    Today I went to change a domain on an account in WHM by using the "Modify Account" option. I changed the domain name and submitted the form but I received the following error..

    Hook denied modification of account: Invalid value for IOPS

    I left all the LVE options empty as always - but now it seems if these fields are left blank during the modify of account, the changes are not accepted.

    I dont think anyone wants to manually enter these settings every time they modify an account.

  • #2
    On a different server I go to Modify Account and there are no LVE settings at all - yet the package options are the same and the LVE manager settings are identical.


    • #3
      We would like to review this situation, please create support ticket with us and provide steps to reproduce the issue. Something must be configured wrong.


      • #4
        There have been no configuration changes at the server. Its not a config issue but I think its caused by a change in the way your software works with the packages.

        If I edit the package in WHM, the LVE settings all say DEFAULT as they were previously - but If I simply save the package - those fields are now populated with the actual figures from LVE manager. This is the first time that has happened. As mentioned, before each field was populated with the word DEFAULT and that was the way until now.

        So Im sure at some point there has been a change in this behaviour - but it only is updated once the package has been re-saved.

        Once this has been done, I can now modify an account and it adds the LVE limits correctly.


        • #5
          Seems this has started happening on one of our servers recently as well.

          If you populate all the fields with DEFAULT, it works and saves the account.

          Is this a bug introduced by a recent update?


          • #6
            We have the same problem


            • #7
              Same issue here.


              • #8

                Please submit a ticket to, our techs will check the issue in place.


                • #9
                  Something has changed again. The LVE limits no longer appear in the packages. I dont see this as a problem - but Id like to copy the limits to new servers without having to individually set them all on every server.

                  Can you tell me what file the limits are stored in? They are not held within the package files in /var/cpanel/packages


                  • #10

                    We need to have more information about your current setup (packages versions, panel version, etc), so please submit a ticket to


                    • #11
                      Youre saying that the package LVE limits are stored in different locations depending on the cpanel version?

                      How many different places can this info be stored?

                      Why cant you reveal this information? This isnt specific to my environment.

                      Why isnt it documented?


                      • #12

                        Packages limits are stored in /var/cpanel/packages/package_name, for example:

                        Ive mentioned panel version because cPanel constantly improves their API and work with packages extensions (you can refer to this blog post)


                        • #13
                          No. The limits are not saved to those files. I changed the LVE package limits - checked the files, the limits are not included in the package files.

                          Under the cpanel package settings it says...

                          But there are no LVE limits defined here.

                          Can you tell me when this is saved? Does it happen when the package limits are changed? Or does some other process update it? Should I wait until a cron job runs?

                          How can I force it to update these files?

                          These are new servers - running CL7 and cpanel 68.0.16 Do not ask me to raise a support ticket. There is nothing unique about my environment - these are standard install of CL and cpanel. Im sure others would benefit from this discussion. I cant be the only one with this problem.


                          • #14

                            If lve extension is not enabled, the package limits values wont be saved as well.

                            There is one cron task which syncs the packages limits with /etc/container/ve.cfg file (default, custom and packages limits are stored in this file). The task is located in /etc/cron.d/lvemanager-cron file (/usr/bin/cl-syncpkgs is called every 5 minutes)


                            • #15
                              Can you please clarify what you mean by "lve extension" ?

                              Ok so Ive seen this...

                              The screenshot shows that when you create a package, there SHOULD be a tick box at the bottom with the title Extensions, then LVE.

                              This doesnt appear on any of my servers. All Ive done is install CENTOS 7 minimal - then run the cpanel installer which detects my CL license and converts the server to CL during the process.

                              Can you please tell me what I need to do in order to enable the LVE Extension? This is vital to making sure the packages have the correct resources.

                              Also, I set up the package limits via LVE manager can you please tell me - will the limits still hold - even though they are not "tied" into the WHM packages via the LVE extension?