Announcement

Collapse
No announcement yet.

mod_lsapi Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mod_lsapi Problems

    We tried to activate the beta version of mod_lsapi but its not working

    After global activation and trying to acces a php site we found the following logs in apache error_log

    [Thu Jul 24 00:48:05 2014] [error] [client xxxxxxxx] AH01968: mod_lsapi: [host http://www.domain.com] Could not connect to lsphp backend: connect(/tmp/lshttpd/lsapi_application-x-httpd-lsphp_645.sock) failed: 2 No such file or directory
    sulsphp policy violation: see its log for more details
    sulsphp policy violation: see its log for more details

    Where can i find the log mentioned to see more details or is anything else missing in our system.

    Regards

  • #2
    Now after uninstalling the module im having problems activating standar suexec module:

    [2014-07-24 01:01:30]: CageFS jail error Unable to mount /tmp/lshttpd -> /usr/share/cagefs-skeleton/tmp/lshttpd: No such file or directory
    I find that kind of errors in suexec_log

    Comment


    • #3
      Hello,

      Create, please, directory /tmp/lshttpd
      mkdir -p /tmp/lshttpd
      and remount cagefs

      Can you show me output of:
      /usr/local/apache/logs/sulsphp_log
      ?

      Comment


      • #4
        Can you describe installation steps? Looks like wasn created /tmp/lshttpd directory on install.

        Comment


        • #5
          1 - I created the folder. Remount-all, force-update and restarted apache. But suddenly apache started serving the source of my php files. Big trouble.

          2 - That log sulsphp_log is full of this errors:

          [2014-07-24 00:48:46]: uid: (783/xxxx) gid: (783/xxxx) cmd: /usr/local/bin/lsphp; socket: /tmp/lshttpd/lsapi_application-x-httpd-lsphp_783.sock
          [2014-07-24 00:48:46]: SecureLVE jail error Unable to mount /tmp/lshttpd -> /usr/share/cagefs-skeleton/tmp/lshttpd: No such file or directory

          3 - The installation procedure was the same one in the documentation for cpanel servers.

          Regards

          Comment


          • #6
            Can you describe how did you remove mod_lsapi? mod_lsapi installation script should restore php handler on --uninstall and should create /tmp/lshttpd on --setup.

            Can you get access to server here - https://helpdesk.cloudlinux.com?

            Comment


            • #7
              I installed and removed just like in the docs: http://docs.cloudlinux.com/index.htm...mod_lsapi.html

              The only additional thing i have over my apache config is the nginx module located in:
              http://www.nginxcp.com/

              Anyway after another uninstall i manage to fix the apache and suexec issues (without lsapi). Right now its not possible to reinstall or send you the details. Maybe tomorrow night.

              Regards

              Comment


              • #8
                Any results here ?

                I was giving a try twice to this mod and got almost same problems

                In 1-31 version i enable it for all domain everything seems to work ok but one of addon domains into one of the customers account start to showing its code (main domain is working ok and addon domain was there before mod_lsapi installation) so i remove it....

                Second time I installed think 37 version try to enable it for some domains but phpinfo continue to show cgi/fcgi even wit restarts and apache rebuilds so i remove it and got this 503 after uninstall (think i update to 42 or something before uninstall) .... cloud support found that mount was there for /tmp/lshttpd .... but it was installed /removed exactly by the docs (with copy /paste --setup --uninstall)

                I got only production server so want to be sure before give mod_lsapi a third try...

                Comment


                • #9
                  I tried again in a different server with the same results.

                  Comment


                  • #10
                    Hello,

                    Can you get me access to server here - https://helpdesk.cloudlinux.com? I need to check what of condition of setup command not working and /tmp/lshttpd directory not created or something else. I can say exactly about cause of error and can fix it, without investigation the trouble on the server.

                    Comment


                    • #11
                      Hi,

                      I fixed this for Plesk instance by doing:

                      # tail /var/log/httpd/sulsphp_log -n 2
                      [2014-08-01 15:38:26]: cannot stat program: (/usr/local/bin/lsphp)
                      [2014-08-01 15:44:44]: uid: (10000/stephan) gid: (503/psacln) cmd: /usr/local/bin/lsphp; socket: /tmp/lshttpd/lsapi_application-x-httpd-lsphp_10000.sock

                      ln -s /usr/sbin/sulsphp /usr/local/bin/lsphp
                      cagefsctl --force-update

                      After that my lsapi just works and phpinfo gives:

                      Server API LiteSpeed V6.6

                      Comment


                      • #12
                        For our system we had to do the following steps on our cPanel. I dont think it configured with just the steps from the CloudLinux documentation:

                        1. Install the mod_lsapi from instructions here under cPanel section: http://docs.cloudlinux.com/index.htm...mod_lsapi.html
                        2. In WHM navigate to "Configure PHP & SuExec" and set the PHP 5 handler to "None" -> Save configuration
                        3. Edit the file in /usr/local/apache/conf/conf.d/lsapi.conf (Uncomment all of the settings you need, most importantly the LoadModule, and AddType lines. This enables it for all websites)
                        4. Run command "service httpd restart".
                        5. To verify: If you have a PHP script that runs "phpinfo" it will show you that lightspeed api is running.

                        One thing I noticed is every time we run /scripts/easyapache now, the /usr/local/apache/conf/conf.d/lsapi.conf file gets sections commented out again, so they need to be re-edited.

                        Hope this helps.

                        Comment


                        • #13
                          Hello,

                          thanks, we found error with lsapi.conf restoring on easyapache. Fixed in mod_lsapi 0.1-58 (just released to updates testing)

                          Comment


                          • #14
                            Hello friends
                            I heard
                            Mod_lsapi is for a server that does not have LightSpeed, then this feature activates a mode similar to LightSpeed, but they should never be activated together, which will cause interference that you encounter.

                            Is this true or false citation ??

                            Comment


                            • #15
                              > Hello friends
                              > I heard
                              > Mod_lsapi is for a server that does not have LightSpeed, then this feature activates a mode similar to LightSpeed, but they should never be activated together, which will cause interference that you encounter.
                              > Is this true or false citation ??

                              Hello,
                              Thank you for reaching out! Mod_lsapi is Apache web server module. As a rule, servers use either LiteSpeed web server or Apache. We have not seen a case when both work, so it is simply impossible to enable mod_lsapi with LiteSpeed, since this requires an Apache.
                              If you have any other questions, feel free to ask here. Thank you for contacting us.

                              Comment

                              Working...
                              X