No announcement yet.

How do you remove Cloudlinux for Directadmin?

  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by grabacontroller View Post
    I fixed it. All I had to do is install the linux headers via yum and reboot the server.
    Were there any other changes? As the headers does not seem to be the reason of the issue.
    Last edited by; 09-25-2023, 05:02 AM.

    Leave a comment:

  • grabacontroller
    I fixed it. All I had to do is install the linux headers via yum and reboot the server.

    Leave a comment:

    Is this the first time you are trying to install CloudLinux on this server? Have you had any issues updating non CloudLinux kernel there? I am wondering since /etc/grub2.cfg is not a default one, likely that is the issue. It's pretty dangerous to give recommendations remotely, however likely renaming the /etc/grub2.cfg and creating a symbolic link to /boot/grub2/grub.cfg could be solution.

    Anyway, if you are looking on how to uninstall CloudLinux please do the following (just do not paste the "$" symbol:

    wget -O cldeploy
    sh cldeploy -cā€‹

    Leave a comment:

  • How do you remove Cloudlinux for Directadmin?

    It seems like it keeps erroring and now I can't install nginx, redis, php, etc.
    sh cldeploy -c
    -bash: $: command not found
    [root@server custombuild]# yum install kernel
    Loaded plugins: fastestmirror, rhnplugin
    This system is receiving updates from CLN.
    Loading mirror speeds from cached hostfile
     * base:
     * cloudlinux-x86_64-server-7:
     * epel:
     * extras:
     * updates:
    Resolving Dependencies
    --> Running transaction check
    ---> Package kernel.x86_64 1:3.10.0-962.3.2.lve1.5.81.el7 will be installed
    --> Processing Dependency: lve >= 1.4-1.13 for package: 1:kernel-3.10.0-962.3.2.lve1.5.81.el7.x86_64
    --> Running transaction check
    ---> Package lve.x86_64 0:2.1-14.el7.cloudlinux will be installed
    --> Finished Dependency Resolution
    Dependencies Resolved
            Arch   Version                           Repository                  Size
     kernel x86_64 1:3.10.0-962.3.2.lve1.5.81.el7    cloudlinux-x86_64-server-7  39 M
    Installing for dependencies:
     lve    x86_64 2.1-14.el7.cloudlinux             cloudlinux-x86_64-server-7  63 k
    Transaction Summary
    Install  1 Package (+1 Dependent package)
    Total download size: 39 M
    Installed size: 167 M
    Is this ok [y/d/N]: y
    Downloading packages:
    No Presto metadata available for cloudlinux-x86_64-server-7
    (1/2): kernel-3.10.0-962.3.2.lve1.5.81.el7.x86_64.rpm      |  39 MB  00:00:00
    (2/2): lve-2.1-14.el7.cloudlinux.x86_64.rpm                |  63 kB  00:00:00
    Total                                                 31 MB/s |  39 MB  00:01
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
      Installing : 1:kernel-3.10.0-962.3.2.lve1.5.81.el7.x86_64                   1/2
      Installing : lve-2.1-14.el7.cloudlinux.x86_64                               2/2
    /sbin/dracut: line 1215: /proc/crypto: No such file or directory
    Could not find bootloader configuration file.
    [WARNING]    /etc/grub2.cfg is not a link
    [WARNING]    /etc/grub2.cfg points to the wrong file instead of /boot/grub2/grub.cfg
    [WARNING]    Kernel 3.10.0-962.3.2.lve1.5.81.el7.x86_64 GRUB entry is missing
    [ERROR]    Kernel 3.10.0-962.3.2.lve1.5.81.el7.x86_64 initramfs GRUB entry is missing and cannot be automatically added due to unknown reasons, please fix GRUB config manually
      Verifying  : lve-2.1-14.el7.cloudlinux.x86_64                               1/2
      Verifying  : 1:kernel-3.10.0-962.3.2.lve1.5.81.el7.x86_64                   2/2
      kernel.x86_64 1:3.10.0-962.3.2.lve1.5.81.el7
    Dependency Installed:
      lve.x86_64 0:2.1-14.el7.cloudlinux