Announcement

Collapse
No announcement yet.

Nightly update, yum update problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nightly update, yum update problem

    Hello,
    a while ago cPanel started to send e-mail after every night update with a msg as below:

    "cPanel & WHM update failure in upcp script.
    Maintenance ended; however, it did not exit cleanly (256). The following events were logged: "scripts/rpmup". Review the update logs to determine why the update failed."

    Log-file says:
    ** Found 3 pre-existing rpmdb problem(s), yum check output follows:
    1:kmod-e1000e-3.10.0-714.10.2.lve1.4.65.el7.x86_64-3.3.5.3-49.el7.x86_64 has missing requires of kernel-uname-r = (0, 3.10.0, 714.10.2.lve1.4.65.el7.x86_64)
    1:kmod-ixgbe-3.10.0-714.10.2.lve1.4.65.el7.x86_64-4.5.4-50.el7.x86_64 has missing requires of kernel-uname-r = (0, 3.10.0, 714.10.2.lve1.4.65.el7.x86_64)
    1:kmod-lve-3.10.0-714.10.2.lve1.4.65.el7.x86_64-1.4-65.el7.x86_64 has missing requires of kernel-uname-r = (0, 3.10.0, 714.10.2.lve1.4.65.el7.x86_64)

    What can we do to resolve it?
    any help to solve this problem greatly appreciated!

    //A

  • #2
    Howdy,

    Lets rebuild that RPM database and see if the rest of this clears up. First thing I would do is follow this guide to rebuild your RPM database.

    https://support.cpanel.net/hc/en-us/...n-RPM-database

    Thanks!

    Comment


    • #3
      Ok, thanks for answering!
      I will try that later tonight (before the next scheduled update), and post an outcome, of course.

      Comment


      • #4
        Well,
        I tried to rebuild RPM database directly via WHM - worked well.
        But the nightly /scheduled updated still didnt go through - same Error as before.

        Then I tried:
        # yum clean all
        # yum update

        but still getting an error with missing dependencies.

        For now just used:
        # yum update --skip-broken

        to get around the problem and apply the updates -> worked OK (there were quite a few updates

        But we still need to fix that issue.
        Any ideas what could be the problem here? Suggestions?

        Comment


        • #5
          Howdy Alexx,

          Would you please open a ticket to resolve the dependency and find out how we got into this dependency mismatch?

          Thanks!

          Comment


          • #6
            Hello and thanks for the answer!

            1. may I ask what does open a ticket means? what will be required from our part?

            2. Concerning our problem with dependency mismatch.. I also see this Error msg when trying to use
            Selector under CloudLinux Manager in WHM (started at some point, worked before):
            =============================================
            "Looks like your PHP handler doesnt support CloudLinux PHP Selector and as a result does not work:
            It looks like you use mod_ruid

            CloudLinux PHP Selector doesnt work properly with it.
            How to delete mod_ruid and install mod_suexec in cPanel
            https://docs.cloudlinux.com/cloudlin...installation-5]"
            =============================================

            Shall we perhaps recompile EasyApache4 with mod_suexec instead of mod_ruid ?
            and see if that will fix the issue to perform an update..

            Any potential consequences we shall be aware of while swapping from mod_ruid to mod_suexec?

            Comment


            • #7
              Howdy Alexx,

              Please follow the instructions here https://www.cloudlinux.com/support/ for a ticket with technical support. EasyApache4 no longer uses compiled from source and mod_ruid support may no longer be supported at all.

              Thanks!

              Comment

              Working...
              X