No announcement yet.

CageFS creating cron problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • CageFS creating cron problems

    Cannot run cron when user is inside CageFS

  • #2
    Ok, I posted messages on cPanels forum and then a cPanel support technician SSHed to my server an hour ago and found the problem I was having is related to CageFS, so he told me to come here.

    Ive been having major cron issues on a few Cloudlinux servers I run. Some of these are running sites with WordPress and others with WHMCS and all have cron permissions issues.

    For example, the cPanel technician just told me this about one particular server:

    > It appears that the issue is actually related to CageFS (which is part of CloudLinux)
    > After taking the user out of CageFS, I can run the PHP command without issue:
    > [server] Alerts:
    > [7559637] [/home/user/public_html]$ cagefsctl --disable username
    > [server] Alerts:
    > [7559637] [/home/user/public_html]$ su - username
    > Attempting to create directory /home/user/perl5
    > -- removed --
    > After putting the user back into CageFS, I am no longer able to run it and get the same error.

    Basically I have been seeing cron not having permissions to run on different accounts across different servers. Is there any troubleshooting you can suggest I can run to test other configs?

    Thank you


    • #3
      Hello D D,

      I worry I have no ready answer for you, would like to investigate the issue in place. Please create support ticket at .


      • #4
        Actually, there is known issue with cpanel 11.56 and paper lantern theme when added cronjobs are being ignored. Switching to X3 theme makes it working.

        The issue is somewhere on cPanel side and we just have internal case ID: CPANEL-6197


        • #5
          Thanks for your help. I modified all accounts away from paper_lantern and to x3 instead. I then went into the account and deleted all cronjobs and then re-created them within x3 theme. I then saved.

          My first cron on WHMCS is set for every 15 minutes and just ran, but I again get this same error:

          .genericError {
          border: 1px dashed #CC0000;
          font-family: Tahoma;
          background-color: #FBEEEB;
          padding: 10px;
          color: #CC0000;
          Critical Error
          Could not connect to the database.
          I will create a helpdesk ticket.