Announcement

Collapse
No announcement yet.

Endusers hitting Limits

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Endusers hitting Limits

    Hi everyone,

    the past 3 months I am trying to learn and discover all Features of having your own Dedicated Server with WHM, cPanel, CloudlinuxOS and ImunifyAV+ . So I figure out almost any base issue I had. I want this Dedicated Server to have 3 main Packages for enduser or resellers (check image below) :

    Click image for larger version

Name:	chrome_NTMxg2y3WP.png
Views:	338
Size:	31.0 KB
ID:	39024

    I first created those 3 packages insdie WHM and then I went to Cloudlinux Manager and I manage to edit those 3 packages similar to the offers we provide to our Customers.
    So I did this:

    Click image for larger version

Name:	chrome_rgG9CQvIzm.png
Views:	317
Size:	26.0 KB
ID:	39025















    I have tottaly 8 users and the 2 of them are just inactive Users and on Cloudlinux Manager it says "Endusers hitting limits" but I do not see any user hitting those limits inside the Statistics.

    Click image for larger version

Name:	chrome_ywWqN1lNIr.png
Views:	313
Size:	39.5 KB
ID:	39026

    What is the potential problem or setting or issue that I did wrong and I see always Users hittings limits. Those Users has Wordpress only and none of them have any Heavy plugins or ecommerce. Also all my Websites are running perfect with no issues.

    Thanks!

  • #2
    Hi,

    The best option is to check the lveinfo database itself for any faults by the last 24 hours, this is a command to use:

    Code:
    lveinfo --by-faults=any --period=24h --display-username
    After you have a user you may want to check the reason of why this happened with the lve-read-snapshot​ tool.

    Comment


    • #3
      Thanks for your answer , I am not so familiar with Terminal. I wrote the Code and I got this error. Also I wrote at the "username" one of my accounts and again the same.

      Code:
      lveinfo: error: unrecognized arguments: --by-faults=any

      Comment


      • #4
        Ah sorry for the misinformation, it have to be this way:

        Code:
        lveinfo --by-fault=any --period=24h --display-username

        Comment


        • #5
          So I got those Accounts , but I am too newbie to understand if something is wrong with them.

          Click image for larger version

Name:	chrome_5uY9cfbImF.png
Views:	472
Size:	118.6 KB
ID:	39032

          Attached Files

          Comment


          • #6
            Thanks for the screenshot, it helps understand what is going on there

            You have to pay attention to the columns with 'f', then the actual faults.

            The first four accounts are hitting CPU limits (fCPU not displayed, but maxCPU=limitCPU here). This means during some moments they were hitting their limits and processes for those LVE were throttled (slowed). This could happen during some spikes or cronjobs.
            The first one is also hitting his physical memory limit - it's critical as in such cases the processes are killed which may result in error 503 in the browser. The common case is when CPU limits are not enough, the processes are slowed and accumulating, as a result, they are hitting the PMEM limit. You may want to monitor for some more days and use the lve-read-snapshot to find the details of when it's happening. And I guess as the result you may want to increase CPU limit for it.


            The last one was hitting IOlimit, this usually happens when some plugins are doing a website backup. And once again, the process is just slowed for this LVE until it's finished.

            The 5th account on the list is pretty strange, no faults are displayed here, most likely some limits were tuned for him during the last 24 hours or so.

            Comment


            • #7
              All those Accounts every night are doing an All in One Backup so maybe the Plugin is hitting the I/O Limits when it "writes" the backup file until will be upload to our FTP Server, I do not have any other plugin doing read and write process. All Accounts has more than 4GB PMemory, is it a little bit strange hitting PMEM limits with this RAM available? Maybe because 3 of them has a Video in their Home Page?

              Also this Dedicated Server has 12 Core and 32GB RAM. Do you believe that giving them 200% CPU Speed is not enough ? Because in theory such a Dedicated Server can Handle up to 250 websites I think. Maybe I am wrong. Thanks a lot for your Help.

              Now I am seeing 4 Accounts Hitting Limits and when I click "Details" I see this all the "F" are with 0 . I check last 4 hours and I see 1 account has 37 F on I/O . How much I/O is good for a Woocommerce Store, because set it to 40mb/s .

              At last at Cloudlinux Manager in the Website Monitoring I see 864 Total Number of Requests / 672 Successful / 192 with Errors. When I check below for those Errors I see for domains , 2 of them is addon domains that are not even work "ghost" addons domains like test.com (main domain) demo.com (addon domain) and the fault are in demo.test.com with status 523

              The other 2 domains are with Statuses 503, those 2 domains are with Maintenance mode on so this is why I have this Result?
              Last edited by jeisblack; 01-29-2023, 10:40 AM.

              Comment


              • #8
                First of all please understand that nothing is wrong here. CloudLinux does the job that it is designed to do - it keeps the users within their LVE limits, preventing the server from being overloaded

                Yes, the backup plugins are likely the reason of the high IO. The 40 Mb/s seems reasonable, I would stay with that value.

                The 200% CPU is enough for high-traffic websites, so yes please increase it from 150 to 200. It's not a matter of the number of websites on a server, you see here short spikes. When a user hits a CPU limit all the processes are throttled and as a result, they are working slower.

                I guess the domains with 503 errors are related to pmem faults, are there any further details of 503 error? Please try to use lve-read-snapshot for a user which domains belongs to, this way:

                Code:
                lve-read-snapshot --period 1d --user USERNAME

                Comment


                • #9
                  Ok, so I increase yesterday the CPU Limits and a little bit the I/O and today I do not have any Limit Problems. At Least for the last 8 hours. Those domains with 503 and 523 Errors are Websites with maintaince mode and domains that do not even work as I mentioned Maybe this is the reason? Cloudinux Manager doen't say where is those errors just the number of errors regarding Requests.

                  Click image for larger version

Name:	chrome_ZNVN4gSe3f.png
Views:	414
Size:	25.8 KB
ID:	39038

                  Comment


                  • #10
                    Are those 503/523 websites also use wordpress? Some systems do show 503 error code when maintenance mode is enabled, if I am not wrong the PrestaShop does that. What is the status code when you open any of this website with curl? Usually the very first line in:

                    Code:
                    curl -I https://forum.cloudlinux.com/

                    Comment


                    • #11
                      Those 2 domains has wordpress installed , the one of them I have enable Maintaince Mode from Elementor Plugin and when you open the website you can see the Coming Soon page. The other one has Maintaince Mode on from Wordpress Toolkit of WHM.

                      Also about the Faults, it is for sure the Backup Plugin , I monitored and I have IOf only the time that the plugin is doing those backups. Is there any way to exclude only this plugin process from limits. I know it is not something wrong with it and this is normal.

                      Comment


                      • #12
                        For the errors I believe you have to review the apache logs to find the places where they are happening. I would grep for errors like this way:

                        Code:
                        cat /usr/local/apache/domlogs/domain* | egrep "503|523"
                        About backup plugins - there is no way to exclude this plugin from limits. If the speed does matter please increase iolimits even more.

                        Comment


                        • #13
                          So I run the code in terminal and I got something about 503 Robots.txt and I assume this is because those domains are closed about a long time.

                          Comment


                          • #14
                            That sounds strange, it should not be 503. Can you please show the record you have got?

                            Comment

                            Working...
                            X