No announcement yet.

PHP Selector - Problem changing php version in newly created accounts (DirectAdmin)

  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP Selector - Problem changing php version in newly created accounts (DirectAdmin)


    I'm facing a problem whenever I create a new user account, where when trying to change the php version an error is returned.

    Despite being able to resolve this issue on a specific account by deactivating and reactivating the user in the "CloudLinux CageFS User Manager" panel, I am being forced to do this every time a new account is created, which is not very efficient.

    Has anyone had a similar situation and managed to resolve the issue?

    DirectAdmin version - 1.642

    CloudLinux version - 8.6
    Attached Files

  • #2

    I guess the defaul user creation mode is not placing them into CageFS. Please check the output of:

    cagefsctl --display-user-mode
    And if you see Disable All then change it to have all new users created with CageFS enabled:

    cagefsctl --enable-all


    • #3
      Thanks for the reply, but unfortunately the problem persists.

      For the new users I had created as a test and who were experiencing this issue, the cagefsctl --enable-all command fixed it, but keeping the issue for new users created after running this command.

      In the latter case could I make a script to run cagefsctl --enable-all periodically ? Or is there anything else I can try to resolve this issue?

      Even though it was already activated, below are the commands I run:

      [root~]# cagefsctl --display-user-mode
      Mode: Enable All
      [root~]# cagefsctl --enable-all
      Mode: Enable All
      Updating users ...
      Updating user ***** ...
      [root ~]# cagefsctl --display-user-mode
      Mode: Enable All


      • #4
        Well, the --enable-all is the workaround, let's better find the root cause to fix it in a proper way. DirectAdmin does display verbose information during user creation progress, any errors there? May you please copy-paste the output of creation progress page?

        Also, please check if /usr/local/directadmin/scripts/custom/user_create_post/ exists.

        And I am also interested in mode for a created user, what is the output of:

        cagefsctl --user-status USERNAME


        • #5
          Hi! Thank you very much for the support so that I can solve this problem.

          Attached is the output of the build progress page.

          Does not exist - /usr/local/directadmin/scripts/custom/user_create_post/

          In the path /usr/local/directadmin/scripts/custom/ there are only README and


          [root ~]# cagefsctl --user-status ztest

          When I access "CloudLinux CageFS User Manage" it also appears as enabled, but the PHP Selector panel returns the same error present in the previous images.

          I assume it could be due to the missing file you mentioned?

          Attached Files


          • #6
            The cagefs status enabled is great to see, also no errors during the account creation progress.

            I believe that one (or some more) scripts could be missing, I would recommend you reinstalling lvemanager package which should trigger post-install scriptlets to be run:

            yum reinstall lvemanager
            Let me know how it goes after that, or if yum shows any errors.

            UPD: I am not a fan of reinstalls, but clearly we are missing some scripts. It is recommended only in this particular case
            Last edited by; 08-16-2022, 07:05 PM.