No announcement yet.

php.ini max upload error

  • Filter
  • Time
  • Show
Clear All
new posts

  • php.ini max upload error

    default php.ini for php7.0

    Have a customer who cannot upload a Wordpress plugin

    error is

    The uploaded file exceeds the upload_max_filesize directive in php.ini.
    I have tried everywhere and cannot get the upload file size fixed so I guess im looking in the wrong place

    The customers cpanel account has php uploads set to 1G in php selector but this is being over ridden somewhere

    Is there somewhere can set a default for this in all php settings 5.6,7.7.1,7.2,7.3 etc ?

    I have edited /opt/alt/php70/etc/php.ini and that doesnt help either

    All CLUES would be greatly appreciated

    CentOS7 Cpanel 86.x CL7.x

  • #2
    Hello Dave,
    Thank you for reaching out! To help you with this question we need a little bit more information, could you please provide us the PHPinfo?
    Thank you.


    • #3
      Interesting - it shows php7.3 being used - yet the customers cpanel php selector is 5.6, just changed it to 7.3 and still the same error, changed to 7.0 and back to 5.6 - all give same error

      php ini file as per 7.3 phpinfo was edited to max upload 1024M - still getting the max upload size error

      php ini 7.3 contains

      ; File Uploads ;
      ; Whether to allow HTTP file uploads.
      ; [URL]
      file_uploads = On
      ; Temporary directory for HTTP uploaded files (will use system default if not
      ; specified).
      ; [URL]([[/URL]
      ;upload_tmp_dir =
      ; Maximum allowed size for uploaded files.
      ; [URL][/URL]
      upload_max_filesize = 1024M


      • #4
        Looking at the php - its Easy apache so perhaps thats why the php selector for CL isnt working - Hmmmm I did turn off the multi php editor for EA4 so It would just use CL multi php - thoughts welcome


        • #5
          For the time being I have edited ea-php 7.3 and have the site uploading in Wordpress - no errors any more (had to also re-enable multi php in feature manager) - however id like to get to the bottom of why CL Multi php isnt working......


          • #6
            Ok after more delving, seems to be a conflict between ea4 php and CL php selector. CL one is not working, in multi php if I select any alt-php version I get red cpanel error boxes and the php wont change from any ea version.


            • #7
              Hello Dave,
              Can you open a support ticket so we can take a closer look at your system? You can post the ticket number here and well link this thread to it.
              Thank you.


              • #8
                Ticket #87610


                • #9
                  > Ticket #87610

                  Thank you, our specialists will answer you on the ticket as quickly as possible.


                  • #10
                    Just a quick follow up

                    Thankyou to GREAT SUPPORT and very quick and knowledgeable replies from

                    Vitaly Nemykin (CloudLinux)


                    Daniil Ivanov (CloudLinux)

                    To cut a long story short - I hadnt disabled php-fpm on most accounts or globally and php version was set to 7.3 on all accounts and not inherit......

                    Changing that fixed all the problems

                    Many thanks chaps


                    • #11
                      Hello Dave,
                      Happy to hear it and thanks for following up!
                      If you have any other questions, feel free to ask here.
                      Thank you for contacting us.