No announcement yet.

lsapi - installation

  • Filter
  • Time
  • Show
Clear All
new posts

  • lsapi - installation

    Im using Cludlinux 7 with cpanel and EasyApache 4

    I installed lsapi based on page:

    but I cant see lsapi_mod in MultiPHP (there are only standard handlers: suphp, cgi and none)
    Should it be visible there ?

    How to enable it ?


  • #2
    I see now. Its strange, that I cant see module lsapi in MultiPHP Handlers, but lsapi overwrites the suphp or cgi.

    All works now, bo not in all versions of php. 5.3 and 7.1 dont work

    I logs I have: "End of script output before headers: ea-php71"

    other php versions have the same modules and settings.



    • #3

      As discussed in - there is no methods to hook into cPanel scripts to show if lsapi is used. So, yes it is normal that cPanel shows suphp/cgi/fcgi whie mod_lsapi is actually in use.

      About "End of script output before headers: ea-php71" - not sure what is going on, we would like to check the issue in place. Please create support ticket with


      • #4
        Problem solved - we needed to edit /etc/container/php.handler and insert additional PHP handlers.


        • #5
          how to get multiphp ini editor to action? The phpinfo() i have information about searching the directory /opt/ etc.. but nothing that is associated with the domain directory client.


          • #6
            Having two selectors is a bit complicated, better to disable one of it with cPanels Feature Manager.

            Please also review documentation how they works together: . As well brief description:


            • #7
              We dont want to have two selectors (multiphp and phpselector). Phpselector is disabled in LVE in WHM.

              We want to have only multiphp. But when it runs lsapi, changing any options in Php.Ini (in users cpanel) nothing changes. In phpinfo in users folder (where we have another Php version) we see that Php reads his settings only from mail Php setting, but not from local Php.ini.

              All we want is using multiphp (lsapi) with possibility to set another Php settings per domain. Is it possible?



              • #8
                I have just performed a bunch of tests (cpanel 62.0(build 16), ea-apache24-mod_lsapi-1.1-4.el7 ) and it works as expected. I can select PHP version from cPanels MultiPHP Manager , and I can change values from cPanels MultiPHP INI Editor. They are reflected properly on phpinfo page.

                I believe I understand the core of your issue. Have you tried same with lsapi disabled?

                As far as I know there is a bug in older cPanel versions (v60 has it):
                1. When you as a cpanel user modify some settings with MultiPHP INI Editor they are saved into /home/username/public_html/php.ini file.

                2. When you as an admin edit some PHP settings from WHM > Software > MultiPHP INI Editor they are saved to /opt/cpanel/ea-php56/root/etc/php.d/local.ini file

                However these local.ini is being processed after users php.ini file so simply overwrites values.

                Starting from version 62.0.1 cPanel writes customers values into their php.ini files and also into .user.ini in same directory. If so - lsapi will use .user.ini and will work properly (in my case).

                Let me know if this helps.