No announcement yet.

Failed ai-bolit-*

  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed ai-bolit-*


    Imunify failed when installing and show the error:

    Failed: ai-bolit-1:31.12.2-1.el8.x86_64
    Failed to install Imunify360 cPanel plugin.

    cPanel and Almalinux 8.

    Please advice​

  • #2
    Hello Maromania,

    Well, AlmaLinux 8 is supported and there should be no issues with cPanel as well. Although, frankly, it is not clear from the log clip provided what was the preceding issue. Seems like after some errors a package dependency - ai-bolit wasn't installed so the cPanel plugins also installation also failed. The issue can be persistent or temporary, you can try the update script:

    wget -O
    bash --key YOUR_KEY
    where YOUR_KEY is your license key, use it if you have it. This will generate ​
    and if the issue reappears, more information can be gathered from this log.

    Edited: I see you probably tried installing Imunify Antivirus before and it also failed for some reason. Could it be some repository issues? What these guys can tell?
    yum repolist
    yum history
    are there failed transactions besides Imunify360?
    In addition to i360deploy.log these commands may also help:
    yum history imunify360-firewall
    yum history info imunify360-firewall | tail -n30
    Please feel free to update the thread.
    Last edited by mchernyavsky; 01-18-2023, 05:26 PM.


    • #3

      Thank you for the clarifications.
      A look to the logs show this error:

      error: unpacking of archive failed on file /opt/ai-bolit/ai-bolit-hoster-trimmed-db.php: cpio: rename failed - Operation not permitted
      error: ai-bolit-1:31.12.2-1.el8.x86_64: install failed​


      • #4
        This is interesting, seems like cpio utility was trying to rename this file, yet failed. There might be issues with the packages that can be solved with:
        yum update
        yum remove -y imunify360-firewall imunify-antivirus
        but this is not expected.

        What will these commands return:
        ls -l /opt/ai-bolit/ai-bolit-hoster-trimmed-db.php
        lsattr /opt/ai-bolit/ai-bolit-hoster-trimmed-db.php
        It seems that you might still have this file with an immutable flag on it after a previously failed transaction, and this prevents the installation of the ai-bolit package. Such a case will require fixing these installations. Or some workarounds and removing remnants as per:

        chattr -i /opt/ai-bolit/ai-bolit-hoster-trimmed-db.php
        ls -l /opt/ai-bolit/
        rm -rfd /opt/ai-bolit/


        • #5
          the result of the rm is
          rm: cannot remove '/opt/ai-bolit/ai-bolit-hoster-trimmed-db.php': Operation not permitted
          rm: cannot remove '/opt/ai-bolit/ai-bolit-hoster.php': Operation not permitted
          rm: cannot remove '/opt/ai-bolit/ai-bolit.php': Operation not permitted
          rm: cannot remove '/opt/ai-bolit/data_collect.php': Operation not permitted
          rm: cannot remove '/opt/ai-bolit/imunify_dbscan.php': Operation not permitted
          rm: cannot remove '/opt/ai-bolit/procu2.php': Operation not permitted
          rm: cannot remove '/opt/ai-bolit/config.ini': Operation not permitted​


          • #6
            I renamed the folder /opt/ai-bolit/ to '/opt/ai-bolit2/ and I reinstalled Imunify.
            The scanning is working now.
            I cannot delete /opt/ai-bolit2 Error Permission denied.

            Thank you for the help.


            • #7
              I cannot delete /opt/ai-bolit2 Error Permission denied.
              It is likely that attributes need to be checked.

              Although, Maromania, it seems that aibolit 31.12.2-1 is in beta right now and it's the first version of aibolit to be self-produced. You may help developers by creating a ticket with CloudLinux Imunify Support. Of cause if it will be possible to provide remote access as well 😀

              The scanning is working now.
              No problem!