Announcement

Collapse
No announcement yet.

Cant install DBGovernor for MySQL 8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant install DBGovernor for MySQL 8

    Hi,

    Im using cloudlinux on WHM server and I want to setup DB Governor. Because Im using MySQL 8.0.23, for long time DB governor for that version of MySQL was in beta.

    Before 10 days I saw blog post about rolling dbgovernor update for mysql 8 in production. I saw that on this url:

    https://blog.cloudlinux.com/mysql-an...led-out-to-100

    My system information:

    Linux 3.10.0-962.3.2.lve1.5.39.el7.x86_64 #1 SMP Thu Sep 17 06:10:33 EDT 2020 x86_64 x86_64 x86_64 GNU/Linux

    Mysql Server version: 8.0.23 MySQL Community Server - GPL

    I set

    /usr/share/lve/dbgovernor/mysqlgovernor.py --mysql-version=mysql80

    and run installation

    /usr/share/lve/dbgovernor/mysqlgovernor.py --install

    I got this output:

    > Start download current installed packages
    > URL http://httpupdate.cpanel.net/RPM/unk...el7.x86_64.rpm; status 404
    > URL http://httpupdate.cpanel.net/RPM/unk...el7.x86_64.rpm; status 404
    > URL http://httpupdate.cpanel.net/RPM/unk...el7.x86_64.rpm; status 404
    > URL http://httpupdate.cpanel.net/RPM/unk...nux.x86_64.rpm; status 404
    > URL http://httpupdate.cpanel.net/RPM/unk...el7.x86_64.rpm; status 404
    > URL http://httpupdate.cpanel.net/RPM/unk...el7.x86_64.rpm; status 404
    > URL http://httpupdate.cpanel.net/RPM/unk...el7.x86_64.rpm; status 404
    > URL http://httpupdate.cpanel.net/RPM/unk...el7.x86_64.rpm; status 404
    >
    > WARNING!!!! Package mysqlclient15-5.0.91-2.el7.cloudlinux.x86_64 was not downloaded
    > WARNING!!!! Package mysql-community-libs-compat-8.0.23-1.el7.x86_64 was not downloaded
    > WARNING!!!! Package mysql-community-common-8.0.23-1.el7.x86_64 was not downloaded
    > WARNING!!!! Package mysql-community-client-plugins-8.0.23-1.el7.x86_64 was not downloaded
    > WARNING!!!! Package mysql-community-server-8.0.23-1.el7.x86_64 was not downloaded
    > WARNING!!!! Package mysql-community-libs-8.0.23-1.el7.x86_64 was not downloaded
    > WARNING!!!! Package mysql-community-devel-8.0.23-1.el7.x86_64 was not downloaded
    > WARNING!!!! Package mysql-community-client-8.0.23-1.el7.x86_64 was not downloaded
    >
    > Start download packages for new installation
    > Loaded plugins: fastestmirror, rhnplugin, universal-hooks
    > Cleaning repos: EA4 cpanel-addons-production-feed cpanel-plugins cl-ea4 cl-mysql-meta cloudlinux-ea4-rollout-1 cloudlinux-ea4-rollout-10 cloudlinux-ea4-rollout-2 cloudlinux-ea4-rollout-3 cloudlinux-ea4-rollout-4 cloudlinux-ea4-rollout-5
    > : cloudlinux-ea4-rollout-6 cloudlinux-ea4-rollout-7 cloudlinux-ea4-rollout-8 cloudlinux-ea4-rollout-9 cloudlinux-imunify360 cloudlinux-rollout-1 cloudlinux-rollout-10 cloudlinux-rollout-2 cloudlinux-rollout-3
    > : cloudlinux-rollout-4 cloudlinux-rollout-5 cloudlinux-rollout-6 cloudlinux-rollout-7 cloudlinux-rollout-8 cloudlinux-rollout-9 cloudlinux-x86_64-server-7 docker-ce-stable epel mysql-connectors-community
    > : mysql-tools-community mysql57-community mysql80-community wp-toolkit-cpanel wp-toolkit-thirdparties
    > Cleaning up list of fastest mirrors
    > Other repos take up 708 M of disk space (use --verbose for details)
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MySQL-meta-devel-8.0.23-2.el7.cloudlinux.x86_64.rpm was loaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MySQL-meta-8.0.23-2.el7.cloudlinux.x86_64.rpm was loaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MySQL-meta-client-8.0.23-2.el7.cloudlinux.x86_64.rpm was loaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MySQL-meta-client-8.0.23-2.el7.cloudlinux.x86_64.rpm was loaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MySQL-meta-devel-8.0.23-2.el7.cloudlinux.x86_64.rpm was loaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/mysqlclient16-5.1.73-1.el7.cloudlinux.x86_64.rpm was loaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/mysqlclient15-5.0.91-2.el7.cloudlinux.x86_64.rpm was loaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/mysqlclient18-5.5.62-3.el7.cloudlinux.x86_64.rpm was loaded
    >
    > WARNING!!!! Package numactl-devel.x86_64 was not downloaded
    > WARNING!!!! Package numactl.x86_64 was not downloaded
    > WARNING!!!! Package libaio.x86_64 was not downloaded
    > Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MySQL-meta-client-8.0.23-2.el7.cloudlinux.x86_64.rpm was loaded
    > WARNING!!!! Package cl-MySQL80-common was not downloaded
    > WARNING!!!! Package cl-MySQL80-libs was not downloaded
    > WARNING!!!! Package cl-MySQL80-server was not downloaded
    > WARNING!!!! Package cl-MySQL80-client was not downloaded
    > WARNING!!!! Package cl-MySQL80-devel was not downloaded
    > Install of MySQL packages will not be completed because not all new packages have been downloaded

    Can someone tell me what I miss?

    Thank you.

  • #2
    same issue.. in this case i upgrade from mariadb 10.1 to 10.2

    Comment

    Working...
    X