Announcement

Collapse
No announcement yet.

mod_lsapi mysql error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mod_lsapi mysql error

    Hi,
    Just installed mod_lsapi on cpanel server, install went OK but found websites running wordpress get this error:

    > Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    uninstalling mod_lsapi and all now OK. Any suggestions please to what went wrong?

  • #2
    I presume you enabled mysql in php selctor ?

    Comment


    • #3
      Hi,
      Its enabled by default. ( native 5.4) If it wasnt enabled mysql wouldnt be working would it.

      Comment


      • #4
        1. we don use native PHP in mod_lsapi --> as it doesn have lsphp build, and we don rebuild it.
        2. mysql is not working for lsphp from what I can see from this message: "Your PHP installation appears to be missing the MySQL extension which is required by WordPress."
        So, yes... please, check if you have MySQL enabled in PHP selector.

        Comment


        • #5
          In the php selector Mysql is only listed in the native 5.4 version, in other versions its not even listed. This is the instructions we followed ( cagefs already running)
          yum install liblsapi liblsapi-devel --enablerepo=cloudlinux-updates-testing
          $ yum install cpanel-mod-lsapi --enablerepo=cloudlinux-updates-testing

          $ /usr/bin/switch_mod_lsapi --setup
          $ /usr/bin/switch_mod_lsapi --enable-global
          $ service httpd restart

          Comment


          • #6
            Have you installed alt-php ?

            http://<a href="http://docs.cloudlin...ation.html</a>

            Comment


            • #7
              Hello,

              native lsphp for cPanel is copied lsphp 5.4 binary from php selector:

              /usr/local/bin/lsphp -i | grep php.ini
              Configuration File (php.ini) Path => /opt/alt/php54/etc
              Loaded Configuration File => /opt/alt/php54/etc/php.ini

              And it used as non full functional php without extensions (because cPanel haven yet lsphp built by default). You should switch php for user in php selector and enable needed extensions for it.

              Comment


              • #8
                Hello,

                can you send us screenshot of php selector web page for this user? You can create ticket here http://helpdesk.cloudlinux.com/ with screenshots.

                Comment


                • #9
                  Ah! it seems alp-php was not installed.
                  Thanks.

                  Comment


                  • #10
                    Hi,
                    OK installed now and mysql is available to select in other php versions. Questions:
                    On install we choose /usr/bin/switch_mod_lsapi --enable-global do we still have to visit each clients cpanel and select the php version to use mod_lsapi ?
                    Where is mod_lsapi listed? its not in any php version module selector.
                    In the docs section is an example config file, where is this file or what file is it added to?
                    Comand to check this mod is running /status?

                    Comment


                    • #11
                      Hello,

                      1) if you switch on mod_lsapi global, all clients automatically works with mod_lsapi after apache restart

                      2) mod_lsapi not integrated in cPanel web interface yet. You can check it by command: /usr/local/apache/bin/httpd -M | grep lsapi

                      3) for cPanel this file is - /usr/local/apache/conf/conf.d/lsapi.conf

                      4) to check that module running for site, make simple php script (test.php):
                      phpinfo();
                      check it via browser and should be string in output:

                      Server API LiteSpeed V6.6

                      Comment


                      • #12
                        Excellent! all working OK.
                        Thanks for your time and help.
                        Regards.

                        Comment


                        • #13
                          I ran into this issue today as well. I was going to say that it should say that Alt-PHP is required in order to run this successfully but it is already in the documentation. Great work guys keep it up.

                          Comment

                          Working...
                          X