Announcement

Collapse
No announcement yet.

governor-mysql-1.2-97 missing support for mariadb 10.11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • governor-mysql-1.2-97 missing support for mariadb 10.11

    I'm in process of setting up a new server, my first CL server. I want to start with MariaDB 10.11. The version of cPanel I have 114 supports 10.11 and CL's own changelog said that 10.11 support was added in a "beta" release in governor version 1.2-95 (released 9/25/23). There have been two iterations on governor since then 1.2-96, 1.2-97. The 1.2-97 versions is listed as LATEST and STABLE. This is the version installed on my server right now.

    Why does 1.2-97 not have MariaDB 10.11 support? If the changelog says support was added in 1.2-95 and does not say anything about removing it in 1.2-96 or 1.2-97 is it not reasonable to expect 1.2-97 to have support included?

    Also, it's quite strange that 1.2-94 was released the same day as 1.2-95 but is listed "after" 1.2-95 - Is it possible that 1.2-94 accidentally merged code that did not include or removed the 10.11 support by accident?

  • #2
    To follow up, I ran this by support and apparently 10.11 was removed:
    This is regarding a particular case in which MariaDB 10.11 was added to the Governor, and it was showing that it was in beta. But it was available for CL8 only.
    Unfortunately, this task needed to be reopened and the packages were removed due to the mentioned task (CLOS-1737).

    Our team are currently working on the integration and the ETA is 2 weeks. The version 10.11 is not available now.
    Really struggling to understand why the changelog was not updated in a matter that indicates that support was removed. I literally wasted hours of my life trying to get this update done because the changelog said that support should be there when they removed it and then didn't mention it.‚Äč

    Comment


    • #3
      Hi,

      For sure the changelog should have been updated with the correct information of removing MariaDB 10.11. I would feel the same if this happened to me, really sorry for this frustrating situation. We will sort this out, thanks for bringing this to our attention!

      Comment


      • #4
        All good - I mostly just wanted to help the next person that might be trying to make this update, if at all...

        Comment

        Working...
        X